summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-07-29 13:22:42 +0100
committerArun Isaac <arunisaac@systemreboot.net>2023-07-29 13:22:42 +0100
commit5a462c0d3dad9f98b52f0144c5e3601b12912d1d (patch)
treece36ddebc9a33394cc81e627968b6f01bfff904b /gnu/packages
parente43cbeafd1b632f39b08b3644af5230d5350a656 (diff)
downloadguix-5a462c0d3dad9f98b52f0144c5e3601b12912d1d.tar.gz
gnu: hitch: Rewrite grep command to not use perl regexps.
* gnu/packages/web.scm (hitch)[arguments]: Rewrite grep command in a test to
not use perl regexps.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b7be06cd7b..08daac5266 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5958,6 +5958,14 @@ on the fly.")
      `(#:phases (modify-phases %standard-phases
                   (add-before 'check 'pre-check
                     (lambda _
+                      ;; Our grep is compiled without perl regexp support. So,
+                      ;; rewrite the grep command to not use it. \t tab
+                      ;; characters are supported only in perl regexps. So,
+                      ;; put in literal tabs using printf instead.
+                      (substitute* "src/tests/test32-proxy-authority.sh"
+                        (("grep -Pq") "grep -q")
+                        (("extension:\\\\tdefault")
+                         "extension:$(printf '\\011')default"))
                       ;; Most tests attempts to access hitch-tls.org which is
                       ;; unavailable in the build container.  Run them against
                       ;; a dummy local web server instead.