summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 16:09:34 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:21 +0200
commit5e9578a8581c240e3e089085330ecdee1bc2b7b2 (patch)
tree080ca599df9523b5a9ad4fb56e3947ccc995e807 /gnu/packages
parent0f8a700458750f7ec5434149ac56da986c06274e (diff)
downloadguix-5e9578a8581c240e3e089085330ecdee1bc2b7b2.tar.gz
gnu: Add texlive-omegaware-bin.
* gnu/packages/tex.scm (texlive-omegaware-bin): New variable.
(texlive-omegaware)[propagated-inputs]: Add TEXLIVE-OMEGAWARE-BIN.
[synopsis, description]: Improve text.

Change-Id: I472a258799d423c66abc5222ae6ce047ac1e6055
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm46
1 files changed, 44 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d62583cd25..6e35893faa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24202,12 +24202,54 @@ LuaTeX.")
               "06kzz0342h6vvc32ydrzgpqsdqv5l0jbd5finr43fmzqi5jnswil")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
+    (propagated-inputs (list texlive-omegaware-bin))
     (home-page "https://ctan.org/pkg/omega")
-    (synopsis "Documentation for Omega executables")
+    (synopsis "Wide-character-set extension of TeX")
     (description
-     "This package provides the documentation for Omega executables.")
+     "This package provides a development of TeX, which deals in multi-octet
+Unicode characters, to enable native treatment of a wide range of languages
+without changing character-set.  Work on Omega has ceased (the TeX Live
+package contains only support files); its compatible successor is Aleph, which
+is itself also in major maintenance mode only.  Ongoing projects developing
+Omega (and Aleph) ideas include Omega-2 and LuaTeX.")
     (license license:gpl3+)))
 
+(define-public texlive-omegaware-bin
+  (package
+    (inherit texlive-bin)
+    (name "texlive-omegaware-bin")
+    (arguments
+     (substitute-keyword-arguments (package-arguments texlive-bin)
+       ((#:configure-flags flags)
+        #~(delete "--enable-web2c" #$flags))
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (replace 'install
+              (lambda _
+                (let ((bin (string-append #$output "/bin")))
+                  (with-directory-excursion "texk/web2c"
+                    (let ((files '("odvicopy" "odvitype""otangle" "wofm2opl"
+                                   "wopl2ofm" "wovf2ovp")))
+                      (for-each (lambda (t) (invoke "make" t)) files)
+                      (for-each (lambda (f) (install-file f bin)) files))
+                    (with-directory-excursion "omegafonts"
+                      (invoke "make" "omfonts")
+                      (install-file "omfonts" bin))
+                    (with-directory-excursion "otps"
+                      (for-each (lambda (t)
+                                  (invoke "make" t)
+                                  (install-file t bin))
+                                '("otp2ocp" "outocp"))))
+                  (with-directory-excursion bin
+                    (for-each (lambda (l) (symlink "omfonts" l))
+                              '("ofm2opl" "opl2ofm" "ovf2ovp" "ovp2ovf"))))))))))
+    (native-inputs (list pkg-config))
+    (home-page (package-home-page texlive-omegaware))
+    (synopsis "Binaries for @code{texlive-omegaware}")
+    (description
+     "This package provides the binaries for @code{texlive-omegaware}.")
+    (license (package-license texlive-omegaware))))
+
 (define-public texlive-onrannual
   (package
     (name "texlive-onrannual")