summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-05-03 15:28:34 -0300
committerVinicius Monego <monego@posteo.net>2024-05-11 14:24:49 -0300
commit6fa742ab31e80c8748fb0c2b2fd055d008d2b48b (patch)
tree289956ac8530a497ca6ab15e4799ec188e03159a /gnu/packages
parent6b60d54bbc61a6251cb669ab3710504f3df2cff3 (diff)
downloadguix-6fa742ab31e80c8748fb0c2b2fd055d008d2b48b.tar.gz
gnu: python-hy: Update to 0.28.0.
* gnu/packages/python-xyz.scm (python-hy): Update to 0.28.0.
[native-inputs]: Replace python-pytest with python-pytest-next.

Change-Id: I6f465a9c834aea51fd0363ba27f9b0ff7b98e82b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 602bc3ab16..91bad3a582 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18345,7 +18345,7 @@ with a new public API, and RPython support.")
 (define-public python-hy
   (package
     (name "python-hy")
-    (version "0.26.0")
+    (version "0.28.0")
     (source
      (origin
        (method git-fetch)               ; no tests in PyPI release
@@ -18354,7 +18354,7 @@ with a new public API, and RPython support.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1czhh7s81sg0nrnf4zv0ydqi4f7s6sywf4ks4fd59vpx441ca39v"))))
+        (base32 "0fs9ydqlbhmp4l3lf8ap8bksbpmlscm6gz7zf9bv2kmcldkjlzsw"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -18381,7 +18381,7 @@ with a new public API, and RPython support.")
                          " and not test_macro_require"
                          " and not test_requires_pollutes_core"))))))))
     (native-inputs
-     (list python-pytest python-wheel))
+     (list python-pytest-next python-wheel))
     (propagated-inputs
      (list python-funcparserlib))
     (home-page "https://docs.hylang.org/en/stable/")