summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:29:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:53 +0200
commit781ce5c8afdea292d9dfc179868ffb1fdddef22b (patch)
tree2ad4c2d53ec79eb19560ba2ae9e91f2e58cfd299 /gnu/packages
parent268fdf8f8141792a9ef3e2db5da6a07e0d89c22f (diff)
downloadguix-781ce5c8afdea292d9dfc179868ffb1fdddef22b.tar.gz
gnu: Add texlive-mathcommand.
* gnu/packages/tex.scm (texlive-mathcommand): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f14093c441..82895b6ece 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4474,6 +4474,30 @@ Proof, and Logic} by Dave Barker-Plummer, Jon Barwise, and John Etchemendy.")
 several languages not included in that package: BUGS, JAGS, and Stan.")
     (license license:lppl1.3+)))
 
+(define-public texlive-mathcommand
+  (package
+    (name "texlive-mathcommand")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mathcommand/"
+                   "source/latex/mathcommand/"
+                   "tex/latex/mathcommand/")
+             (base32
+              "1vm7k1p5d74vkqmpxdza4127qj7622w0vfr2bh51wb612dpps2a5")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mathcommand")
+    (synopsis "@code{\\newcommand}-like commands for defining math macros")
+    (description
+     "This package provides functionalities for defining macros that have
+different behaviors depending on whether in math or text mode, that absorb
+Primes, Indices and Exponents (PIE) as extra parameters usable in the code;
+and it offers some iteration facilities for defining macros with similar code.
+The primary objective of this package is to be used together with the
+knowledge package for a proper handling of mathematical notations.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")