summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-05 15:58:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-05 22:58:13 -0400
commit79a51c910c46e8d6d8bc1db25bc0fb069bc9944e (patch)
tree9edb7533b6f9b0bfe867e02aabed1ca014e3bf25 /gnu/packages
parent3a1737aaa2b266b6066de2f1b1d47d26bc768ec2 (diff)
downloadguix-79a51c910c46e8d6d8bc1db25bc0fb069bc9944e.tar.gz
gnu: mupen64plus-ui-console: Modernize.
* gnu/packages/emulators.scm (mupen64plus-ui-console)
[propagated-inputs]: Remove legacy mupen64plus-video-glide64 plugin.
[arguments]: Use gexps.

Change-Id: I33ce0ef1e7ea87b382f74aae07098bcf0e5f30e0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emulators.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 4dd8a9a5d4..9cbfd25643 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1318,29 +1318,27 @@ Z64 video plugin.")
            mupen64plus-audio-sdl
            mupen64plus-input-sdl
            mupen64plus-rsp-hle
-           mupen64plus-video-glide64
            mupen64plus-video-glide64mk2
            mupen64plus-video-rice))
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         ;; The mupen64plus build system has no configure phase.
-         (delete 'configure)
-         ;; Makefile is in a subdirectory.
-         (add-before
-          'build 'cd-to-project-dir
-          (lambda _
-            (chdir "projects/unix"))))
-       #:make-flags
-       (let ((out (assoc-ref %outputs "out"))
-             (m64p (assoc-ref %build-inputs "mupen64plus-core")))
-         (list "all"
-               (string-append "PREFIX=" out)
-               (string-append "APIDIR=" m64p "/include/mupen64plus")
-               ;; Trailing slash matters here.
-               (string-append "COREDIR=" m64p "/lib/")))
-       ;; There are no tests.
-       #:tests? #f))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; The mupen64plus build system has no configure phase.
+          (delete 'configure)
+          ;; Makefile is in a subdirectory.
+          (add-before 'build 'cd-to-project-dir
+            (lambda _
+              (chdir "projects/unix"))))
+      #:make-flags
+      #~(let ((m64p #$(this-package-input "mupen64plus-core")))
+          (list "all"
+                (string-append "PREFIX=" #$output)
+                (string-append "APIDIR=" m64p "/include/mupen64plus")
+                ;; Trailing slash matters here.
+                (string-append "COREDIR=" m64p "/lib/")))
+      ;; There are no tests.
+      #:tests? #f))
     (home-page "https://www.mupen64plus.org/")
     (synopsis "Mupen64Plus command line user interface")
     (description