summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 13:08:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 13:09:26 +0300
commit7a0077d7f39f7d77b3afb57311c03cded68620a9 (patch)
treeec772c4a32cc81907ccebb9fe75ea9800b2d4e67 /gnu/packages
parentd76e0a36f93b41bac2d42b85fa80079784cd0b76 (diff)
downloadguix-7a0077d7f39f7d77b3afb57311c03cded68620a9.tar.gz
gnu: python-pytest-mock: Adjust package inputs.
* gnu/packages/check.scm (python-pytest-mock)[propagated-inputs]: Move
python-pytest-asyncio ...
[native-inputs]: ... to here.
(python2-pytest-mock): Adjust to ensure package remains unchanged.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c6c078b08f..cc2cd5e1f8 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1334,10 +1334,10 @@ reported in a previous test run.")
                (invoke "pytest" "--assert=plain"
                        "-k" "not test_standalone_mock")))))))
     (native-inputs
-     `(("python-setuptools-scm" ,python-setuptools-scm)))
+     `(("python-pytest-asyncio" ,python-pytest-asyncio)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
     (propagated-inputs
-     `(("python-pytest" ,python-pytest)
-       ("python-pytest-asyncio" ,python-pytest-asyncio)))
+     `(("python-pytest" ,python-pytest)))
     (home-page "https://github.com/pytest-dev/pytest-mock/")
     (synopsis "Thin-wrapper around the mock package for easier use with py.test")
     (description
@@ -1363,6 +1363,8 @@ same arguments.")
            "1i5mg3ff1qk0wqfcxfz60hwy3q5dskdp36i10ckigkzffg8hc3ad"))))
       (arguments
        `(#:python ,python-2))
+      (native-inputs
+       `(("python2-setuptools-scm" ,python2-setuptools-scm)))
       (propagated-inputs
        `(("python2-mock" ,python2-mock)
          ("python2-pytest" ,python2-pytest))))))