summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-07-04 14:39:16 +0200
committerRoel Janssen <roel@gnu.org>2016-07-04 14:39:16 +0200
commit7d4224d7942868d3cdcf2438dcb5a2f9e46f2f07 (patch)
treeeadbb204dca060370f0a1845bb17df71b007c521 /gnu/packages
parent7034791aa25db02e392495c44d68a5de937bdf7a (diff)
downloadguix-7d4224d7942868d3cdcf2438dcb5a2f9e46f2f07.tar.gz
gnu: Add r-limma.
* gnu/packages/bioinformatics.scm (r-limma):  New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index caab01ddd1..05c3b7f7b9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4469,6 +4469,25 @@ names in their natural, rather than lexicographic, order.")
 coding changes and predict coding outcomes.")
     (license license:artistic2.0)))
 
+(define-public r-limma
+  (package
+    (name "r-limma")
+    (version "3.28.14")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "limma" version))
+              (sha256
+               (base32
+                "1jgn66ajafhjlqpfcw2p85h6ah8mgmz66znmsw6pcapia7d34akw"))))
+    (build-system r-build-system)
+    (home-page "http://bioinf.wehi.edu.au/limma")
+    (synopsis "Package for linear models for microarray and RNA-seq data")
+    (description "This package can be used for the analysis of gene expression
+studies, especially the use of linear models for analysing designed experiments
+and the assessment of differential expression.  The analysis methods apply to
+different technologies, including microarrays, RNA-seq, and quantitative PCR.")
+    (license license:gpl2+)))
+
 (define-public r-xvector
   (package
     (name "r-xvector")