summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-05 23:24:30 +0100
committerChristopher Baines <mail@cbaines.net>2023-09-13 09:22:20 +0100
commit7f150a18957daddb53caf11e23eb12122198d65c (patch)
tree3775509e697340c318087e3574d1194d54117522 /gnu/packages
parentde2ee9cae67079daf380f09c095f2a4b37be40e6 (diff)
downloadguix-7f150a18957daddb53caf11e23eb12122198d65c.tar.gz
gnu: python-qtsass: Update to 0.4.0.
This also fixes test failures preventing the package from building.

* gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix build.
[native-inputs]: Add python-flaky.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ba51ca654..dd43fb3cd1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29978,7 +29978,7 @@ applications and daemons.")
 (define-public python-qtsass
   (package
     (name "python-qtsass")
-    (version "0.3.0")
+    (version "0.4.0")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -29988,7 +29988,7 @@ applications and daemons.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "09s04aa14d8jqbh71clrb5y7vcmkxlp94mwmvzrkxahry3bk03cb"))))
+        (base32 "1skdihfby2f41zxgwa5zv44vdxjrw301rh88rjmzj4xbdlix6cig"))))
     (build-system python-build-system)
     (arguments
      `(#:test-target "pytest"
@@ -30000,7 +30000,7 @@ applications and daemons.")
              (for-each make-file-writable (find-files "."))
              #t)))))
     (native-inputs
-     (list python-pytest python-pytest-cov python-pytest-runner))
+     (list python-flaky python-pytest python-pytest-cov python-pytest-runner))
     (propagated-inputs
      (list python-libsass))
     (home-page "https://github.com/spyder-ide/qtsass")