summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarco Rimoldi <rimarko@libero.it>2024-02-21 20:30:34 +0100
committerChristopher Baines <mail@cbaines.net>2024-03-16 10:05:23 +0000
commit82bb2ed9c95fef84b2fbbe143f69502b62765e56 (patch)
treedf355266020ca569951651762e71c33c1fa68528 /gnu/packages
parentcf0f8918f654584f544e8618f8d84c47e940ead0 (diff)
downloadguix-82bb2ed9c95fef84b2fbbe143f69502b62765e56.tar.gz
gnu: portmidi: Add variant portmidi-2 updated to release 2.0.4.
Tested with package Frescobaldi.  Other packages dependent on the old 217
version still need to be tested and updated so that it can be phased out.

* gnu/packages/music.scm (portmidi): Add variant portmidi-2.
[version]: Change to new scheme, jumping from 217 to 2.0.4.
[source]: Change origin from Sourceforge to GitHub.
* gnu/packages/music.scm (python-pyportmidi) [inputs]: Change portmidi to portmidi-2.
* gnu/packages/music.scm (frescobaldi) [inputs]: Change portmidi to portmidi-2.

Change-Id: I2530d206e19e885082a95f1aac65348e7a51d4ca
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm37
1 files changed, 35 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1bc563a190..7f0467e766 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3040,6 +3040,39 @@ main purpose is to liberate raw audio rendering from audio and MIDI drivers.")
 using a system-independent interface.")
     (license license:expat)))
 
+(define-public portmidi-2
+  (package
+    (name "portmidi")
+    (version "2.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/PortMidi/portmidi")
+             (commit "b808babecdc5d05205467dab5c1006c5ac0fdfd4")))
+       (sha256
+        (base32 "05a3dfpgbpcg08p8a3acjrrd1qy5hvvray2kz2asygy1vf3mx85s"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f       ;Tests are interactive and can be found in the
+       #:configure-flags ;pm_tests/ directory of the build tree.
+       (list "-DBUILD_PORTMIDI_TESTS=On")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'fix-version
+                    (lambda _
+                      (substitute* "CMakeLists.txt"
+                        (("2.0.3")
+                         (version))))))))
+    (inputs (list alsa-lib))
+    (native-inputs (list unzip))
+    (home-page "https://github.com/PortMidi/")
+    (synopsis "Library for MIDI I/O")
+    (description
+     "PortMidi is a library supporting real-time input and output of MIDI data
+using a system-independent interface.")
+    (license license:expat)))
+
 (define-public python-pyportmidi
   (let ((commit "d9e5ee00b208b09618fa0d4a5bbce3c9c077b386")
         (revision "0"))
@@ -3056,7 +3089,7 @@ using a system-independent interface.")
           (base32 "1jvp9na8d1hw46w9ybhkimbavfb3ysw7hp30cbk6dj40k5y5vgvz"))
          (file-name (git-file-name name version))))
       (build-system python-build-system)
-      (inputs (list portmidi alsa-lib))
+      (inputs (list portmidi-2 alsa-lib))
       (native-inputs (list python-cython))
       (home-page "https://github.com/PortMidi")
       (synopsis "Python bindings to PortMidi")
@@ -3091,7 +3124,7 @@ using a system-independent interface.")
     (inputs
      (list lilypond
            poppler
-           portmidi
+           portmidi-2
            python-ly
            python-poppler-qt5
            python-pyportmidi