summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 15:13:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 15:17:18 +0200
commit82c5d929b9d24f6f9f8425959379d4164d48d219 (patch)
tree8bdc3d552622b59c3d209aabf54d4cee8ddb66ed /gnu/packages
parentd7ef77c8edd8cbd53819384ae21442293fd3b8dd (diff)
downloadguix-82c5d929b9d24f6f9f8425959379d4164d48d219.tar.gz
gnu: python-nbconvert: Use modular texlive packages.
* gnu/packages/python-xyz.scm (python-nbconvert)[inputs]: Remove texlive.
[native-inputs]: Add texlive-union.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm53
1 files changed, 41 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 516a120a22..1cdce8625f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10877,18 +10877,47 @@ time.")
                (setenv "HOME" "/tmp")
                (invoke "pytest" "-vv")))))))
     (inputs
-      `(("pandoc" ,pandoc)
-        ; XXX: Disabled, needs substitute*.
-        ;("inkscape" ,inkscape)
-        ("texlive" ,texlive)))
-    (native-inputs
-      `(("python-ipykernel" ,python-ipykernel)
-        ; XXX: Disabled, not in guix.
-        ;("python-pyppeteer" ,python-pyppeteer)
-        ("python-pytest" ,python-pytest)
-        ("python-pytest-cov" ,python-pytest-cov)
-        ("python-pytest-dependency"
-         ,python-pytest-dependency)))
+     `(("pandoc" ,pandoc)
+       ;; XXX: Disabled, needs substitute*.
+       ;;("inkscape" ,inkscape)
+       ))
+    (native-inputs
+     `(("python-ipykernel" ,python-ipykernel)
+       ;; XXX: Disabled, not in guix.
+       ;;("python-pyppeteer" ,python-pyppeteer)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-dependency" ,python-pytest-dependency)
+       ("texlive" ,(texlive-union (list texlive-adjustbox
+                                        texlive-amsfonts
+                                        texlive-booktabs
+                                        texlive-caption
+                                        texlive-eurosym
+                                        texlive-fonts-rsfs
+                                        texlive-generic-ulem
+                                        texlive-iftex
+                                        texlive-jknappen
+                                        texlive-latex-amsmath
+                                        texlive-latex-enumitem
+                                        texlive-latex-fancyvrb
+                                        texlive-latex-float
+                                        texlive-latex-fontspec
+                                        texlive-latex-geometry
+                                        texlive-latex-hyperref
+                                        texlive-latex-jknapltx
+                                        texlive-latex-ms
+                                        texlive-latex-oberdiek
+                                        texlive-latex-parskip
+                                        texlive-latex-trimspaces
+                                        texlive-latex-upquote
+                                        texlive-latex-ucs
+                                        texlive-lm
+                                        texlive-mathpazo
+                                        texlive-tcolorbox
+                                        texlive-titling
+                                        texlive-tools
+                                        texlive-xcolor
+                                        texlive-zapfding)))))
     (propagated-inputs
      `(("python-bleach" ,python-bleach)
        ("python-defusedxml" ,python-defusedxml)