summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre-Evariste Dagand <doc@evr.ist>2023-10-09 09:40:38 +0200
committerLudovic Courtès <ludo@gnu.org>2023-10-11 23:12:56 +0200
commit83dc6c2c68f7f2bc24c03463c0a17cb70dfff5e3 (patch)
treeab65615c78c3985ed63278af4f1a4fc1856d0016 /gnu/packages
parent5b133876cca786c4dc107a28cc66db1879b36c29 (diff)
downloadguix-83dc6c2c68f7f2bc24c03463c0a17cb70dfff5e3.tar.gz
gnu: python-google-api-client: Update to 2.102.0.
* gnu/packages/python-web.scm (python-google-api-client): Update to 2.102.0
(python-google-auth-httplib2): Update to 0.1.1.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0e52f2fdbd..4dcc5b5fb9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5136,22 +5136,23 @@ Google search engine.  Its module is called @code{googlesearch}.")
 (define-public python-google-api-client
   (package
     (name "python-google-api-client")
-    (version "1.12.8")
+    (version "2.102.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "google-api-python-client" version))
        (sha256
         (base32
-         "1fq89wifa9ymby655is246w5d54ixybffj5vz7lwzhpf8926ifgk"))))
+         "07b9afz3g3lk976i974h6ikvl7wzwm0a0ws0iynxvmd4favgjvwh"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f))    ; tests require internet access
     (propagated-inputs
-     (list python-google-api-core-1
-           python-google-auth-1
+     (list python-google-api-core
+           python-google-auth
            python-google-auth-httplib2
            python-httplib2
+           python-pyparsing
            python-six
            python-uritemplate-3))
     (home-page "https://github.com/google/google-api-python-client")
@@ -5162,12 +5163,12 @@ Google search engine.  Its module is called @code{googlesearch}.")
 (define-public python-google-auth-httplib2
   (package
     (name "python-google-auth-httplib2")
-    (version "0.1.0")
+    (version "0.1.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "google-auth-httplib2" version))
               (sha256
-               (base32 "1b1hrhah01hx6bj3rb83iybrdwqv0bbdy63py39srv1bcgykjz50"))))
+               (base32 "0agwwgw04nks7lzpm224fbvpnjfgzz67pkrfls77ipf6zmawajy6"))))
     (build-system python-build-system)
     (propagated-inputs
      (list python-google-auth python-httplib2 python-six))