summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:38:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:38:26 +0100
commit88cdba5ccd021a0016c820fb615e29ca91f06c56 (patch)
treef6744b3e0f83e6943a497687a87b7f2ee4727650 /gnu/packages
parentc1e875eea340e7b14c41c6377df4dde74dee1145 (diff)
downloadguix-88cdba5ccd021a0016c820fb615e29ca91f06c56.tar.gz
gnu: go-github-com-calmh-xdr: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-calmh-xdr): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I201f5147de0a353057206ca314a685eb70622e00
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/syncthing.scm23
2 files changed, 27 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f95e74a4ea..487a8fb1e1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -774,6 +774,33 @@ indicator to any terminal application.")
 similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))
 
+;; XXX: This repository has been archived by the owner on Feb 21, 2018. It is
+;; now read-only.
+(define-public go-github-com-calmh-xdr
+  (package
+    (name "go-github-com-calmh-xdr")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/calmh/xdr")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/calmh/xdr"))
+    (home-page "https://github.com/calmh/xdr")
+    (synopsis "XDR marshalling and unmarshalling")
+    (description
+     "XDR is an External Data Representation (XDR)
+marshalling and unmarshalling library in Go.  It uses code generation and not
+reflection.")
+    (license license:expat)))
+
 (define-public go-github-com-cheggaaa-pb
   (package
     (name "go-github-com-cheggaaa-pb")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7f8e08adb0..3cbf413e63 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -213,29 +213,6 @@ notification area icon for Syncthing.  Supported Syncthing features:
 (define-public qsyncthingtray
   (deprecated-package "qsyncthingtray" syncthing-gtk))
 
-(define-public go-github-com-calmh-xdr
-  (package
-    (name "go-github-com-calmh-xdr")
-    (version "1.1.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/calmh/xdr")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/calmh/xdr"))
-    (synopsis "XDR marshalling and unmarshalling")
-    (description "XDR is an External Data Representation (XDR)
-marshalling and unmarshalling library in Go.  It uses code generation and not
-reflection.")
-    (home-page "https://github.com/calmh/xdr")
-    (license expat)))
-
 (define-public go-github-com-vitrun-qart
   (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
         (revision "0"))