summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:30:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:48:22 +0200
commit89a96b338cebe1a9303b865401ecbc0a530cae21 (patch)
tree0c6062336f8a2c4a6a62fa5fa95934ea7303f245 /gnu/packages
parent962f6fed43dbc098ea0b5503e65b81b4ead836af (diff)
downloadguix-89a96b338cebe1a9303b865401ecbc0a530cae21.tar.gz
gnu: git-annex: Update to 10.20230926.
* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20230926.
[inputs]: Add ghc-git-lfs.

Change-Id: Ic7a1f246e51df2ff153a630d3ebbb9883b63a2d1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-apps.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ad8c2a0757..94e1394c89 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -294,7 +294,7 @@ to @code{cabal repl}).")
 (define-public git-annex
   (package
     (name "git-annex")
-    (version "10.20230828")
+    (version "10.20230926")
     (source
      (origin
        ;; hackage release doesn't include everything needed for extra bits.
@@ -304,7 +304,7 @@ to @code{cabal repl}).")
               (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1k13mspwlpw6wwnf0cjlqcy3563kyprc6s5parrmsh07dysff7fi"))))
+        (base32 "0zsq686b0q7mlkybm1xrc0kpl32ymvf0ybar01p68wx800031b2b"))))
     (build-system haskell-build-system)
     (properties '((upstream-name . "git-annex")))
     (arguments
@@ -422,6 +422,7 @@ to @code{cabal repl}).")
            ghc-feed
            ghc-filepath-bytestring
            ghc-free
+           ghc-git-lfs
            ghc-hinotify
            ghc-http-client
            ghc-http-client-tls