summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSergio Pastor PĂ©rez <sergio.pastorperez@outlook.es>2023-11-28 22:11:51 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:41 +0200
commit8bbc42ba7bc4f081dd3ee85ab7a14d343502882d (patch)
treec464fae5cac804fe30b640fde3f04d8b719915fb /gnu/packages
parentd9fde1e639f481becfb1338650b2ba14fed4a9e5 (diff)
downloadguix-8bbc42ba7bc4f081dd3ee85ab7a14d343502882d.tar.gz
gnu: Add rust-pango-sys-0.18.
* gnu/packages/crates-gtk.scm (rust-pango-sys-0.18): New variable.
(rust-pango-sys-0.17): Inherit from rust-pango-sys-0.18.

Change-Id: I1c5159670be3c67d08942d3e058ef094b9f95c3c
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-gtk.scm38
1 files changed, 28 insertions, 10 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 978cf2d3c8..f73c3478e6 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -2573,8 +2573,35 @@ library.")
        #:cargo-development-inputs
        (("rust-gir-format-check" ,rust-gir-format-check-0.1))))))
 
+(define-public rust-pango-sys-0.18
+  (package
+    (name "rust-pango-sys")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pango-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1iaxalcaaj59cl9n10svh4g50v8jrc1a36kd7n9yahx8j7ikfrs3"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-glib-sys" ,rust-glib-sys-0.18)
+                       ("rust-gobject-sys" ,rust-gobject-sys-0.18)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-system-deps" ,rust-system-deps-6))
+       #:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
+                                   ("rust-tempfile" ,rust-tempfile-3))))
+    (native-inputs (list pkg-config))
+    (inputs (list pango))
+    (home-page "https://gtk-rs.org/")
+    (synopsis "FFI bindings to libpango-1.0")
+    (description "This package provides FFI bindings to @code{libpango-1.0}.")
+    (license license:expat)))
+
 (define-public rust-pango-sys-0.17
   (package
+    (inherit rust-pango-sys-0.18)
     (name "rust-pango-sys")
     (version "0.17.10")
     (source
@@ -2584,7 +2611,6 @@ library.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "15aindwdxsydzvqcvhc9ysamx5v1jmq8qbs61ncxic2h72grz9ix"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-glib-sys" ,rust-glib-sys-0.17)
@@ -2593,15 +2619,7 @@ library.")
         ("rust-system-deps" ,rust-system-deps-6))
        #:cargo-development-inputs
        (("rust-shell-words" ,rust-shell-words-1)
-        ("rust-tempfile" ,rust-tempfile-3))))
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list pango))
-    (home-page "https://gtk-rs.org/")
-    (synopsis "FFI bindings to libpango-1.0")
-    (description "This package provides FFI bindings to @code{libpango-1.0}.")
-    (license license:expat)))
+        ("rust-tempfile" ,rust-tempfile-3))))))
 
 (define-public rust-pango-sys-0.15
   (package