summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:06:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:50 +0200
commit97f316d3dee6f20bad94cffa48b9f846497cd9de (patch)
tree0d27e59dd35e5ddd6daca192de1eb9a760b025d1 /gnu/packages
parentd5dab358661d458b69e235ef7d8d5eba5802772a (diff)
downloadguix-97f316d3dee6f20bad94cffa48b9f846497cd9de.tar.gz
gnu: Add texlive-bartel-chess-fonts.
* gnu/packages/tex.scm (texlive-bartel-chess-fonts): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b3e9825caa..bc18a06b97 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2801,6 +2801,31 @@ and Metafont sources for fonts.")
 of mathematical disciplines.")
     (license license:lppl1.3+)))
 
+(define-public texlive-bartel-chess-fonts
+  (package
+    (name "texlive-bartel-chess-fonts")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/bartel-chess-fonts/"
+                   "fonts/source/public/bartel-chess-fonts/"
+                   "fonts/tfm/public/bartel-chess-fonts/")
+             (base32
+              "1gg7g2gb5j0g0ig4190260zlpnyfmdzcqn7dsw5kp9p5pbn5hbhf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    ;; FIXME: Font metrics generation fails with "! Strange path (turning
+    ;; number is zero)." error.
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'generate-font-metrics))))
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/bartel-chess-fonts")
+    (synopsis "Set of fonts supporting chess diagrams")
+    (description "This package provides fonts supporting chess diagrams.")
+    (license license:gpl3+)))
+
 (define-public texlive-basque-book
   (package
     (name "texlive-basque-book")