summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-02-28 11:35:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-28 11:46:14 +0200
commit9d882d2ef51804e3ddc31b09f62257a5809cb0ba (patch)
tree20c1ee5e931b9b2f830a7e660ef0c98b6275bee1 /gnu/packages
parentaa1d419586c387ba07f323196bfb92b6237b032e (diff)
downloadguix-9d882d2ef51804e3ddc31b09f62257a5809cb0ba.tar.gz
gnu: bowtie1: Enable building on more systems.
* gnu/packages/bioinformatics.scm (bowtie1)[arguments]: Add make-flag to
disable searching for cpu features on non-x86 systems.
[supported-systems]: Enable all 64-bit supported systems.

Change-Id: Ice30df945ba154e39cd58a91847329e81038a3af
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1613961c64..85565f44bd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3775,14 +3775,17 @@ gapped, local, and paired-end alignment modes.")
      `(#:tests? #f                      ; Tests need various perl modules
        #:test-target "simple-test"
        #:make-flags
-       ,#~(list "CC=gcc" "all"
-                (string-append "prefix=" #$output))
+       ,#~(append #$(if (not (target-x86?))
+                        #~'("POPCNT_CAPABILITY=0")
+                        #~'())
+                  (list "CC=gcc" "all"
+                        (string-append "prefix=" #$output)))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))
     (inputs
      (list python-wrapper tbb zlib))
-    (supported-systems '("x86_64-linux"))
+    (supported-systems %64bit-supported-systems)
     (home-page "https://bowtie-bio.sourceforge.net/index.shtml")
     (synopsis "Fast aligner for short nucleotide sequence reads")
     (description