summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-10 15:34:49 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:20 +0800
commita0aff95db93f2730b57fe3411fdf2e1d8eb194ff (patch)
tree9a88ef31a38ac9c47a85787d97d72c9adc99aaf9 /gnu/packages
parentc08b919b67dc1a0b1e6e537bdc19a4b19b8dc84a (diff)
downloadguix-a0aff95db93f2730b57fe3411fdf2e1d8eb194ff.tar.gz
gnu: python-distlib: Don't reference the implicit bash input.
* gnu/packages/python-xyz.scm (python-distlib)[inputs]: Add BASH-MINIMAL.
[arguments]: Use SEARCH-INPUT-FILE instead of WHICH.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b574ec2efe..5445318157 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8551,9 +8551,10 @@ and therefore easier to read and write.")
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'build 'no-/bin/sh
-            (lambda _
-              (substitute* '("distlib/scripts.py" "tests/test_scripts.py")
-                (("/bin/sh") (which "sh")))))
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((/bin/sh (search-input-file inputs "bin/sh")))
+                (substitute* '("distlib/scripts.py" "tests/test_scripts.py")
+                  (("/bin/sh") /bin/sh)))))
           (add-before 'check 'prepare-test-environment
             (lambda _
               (setenv "HOME" "/tmp")
@@ -8561,6 +8562,8 @@ and therefore easier to read and write.")
               (setenv "SKIP_ONLINE" "1"))))))
     (native-inputs
      (list python-pytest))
+    (inputs
+     (list bash-minimal))
     (home-page "https://github.com/pypa/distlib")
     (synopsis "Distribution utilities")
     (description "Distlib is a library which implements low-level functions that