summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-07 14:55:00 +0100
committerMarius Bakke <marius@gnu.org>2023-01-07 21:04:27 +0100
commita6c005dbac90f3e22898c502bd32fdf86d61d38b (patch)
tree25578804b4324e586d0726699cbc87e41ab77029 /gnu/packages
parentaa861a3980ede130080ed492c62b097ee6f2caf7 (diff)
downloadguix-a6c005dbac90f3e22898c502bd32fdf86d61d38b.tar.gz
gnu: Remove python-pyev.
This package fails to build, is no longer on PyPI, and has been inactive
upstream for 10 years.

* gnu/packages/python-xyz.scm (python-pyev): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index df2c7ce52d..d78716107f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19216,35 +19216,6 @@ working with Portable Executable (PE) files.  It makes to most information
 from the header, as well as section details and data available.")
     (license license:expat)))
 
-(define-public python-pyev
-  (package
-    (name "python-pyev")
-    (version "0.9.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "pyev" version))
-        (sha256
-         (base32
-          "0rf603lc0s6zpa1nb25vhd8g4y337wg2wyz56i0agsdh7jchl0sx"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f ; no test suite
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((libev (search-input-file inputs "/lib/libev.so.4")))
-               (substitute* "setup.py"
-                 (("libev_dll_name = find_library\\(\\\"ev\\\"\\)")
-                  (string-append "libev_dll_name = \"" libev "\"")))))))))
-    (inputs
-     (list libev))
-    (home-page "https://github.com/gabrielfalcao/pyev")
-    (synopsis "Python libev interface")
-    (description "Pyev provides a Python interface to libev.")
-    (license license:gpl3)))
-
 (define-public python-imagesize
   (package
     (name "python-imagesize")