summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-10-27 08:58:22 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-10-27 08:58:42 -0700
commitaf4ce7bd413c3a50733bfcc05370903a1e3808bc (patch)
treedf01591036c0469a28b0e7ac603fe0fb59634ff3 /gnu/packages
parent2efc7819ce083f246d60ef1be2301568f4be4f9e (diff)
downloadguix-af4ce7bd413c3a50733bfcc05370903a1e3808bc.tar.gz
gnu: diffoscope: Update to 188.
* gnu/packages/patches/diffoscope-fix-test_item3_deflate_llvm_bitcode.patch:
  Rename patch to...
* gnu/packages/patches/diffoscope-fix-llvm-test.patch: This.
* gnu/local.mk (dist_patch_DATA): Update patch name.
* gnu/packages/diffoscope.scm (diffoscope): Update to 188.
  [source]: Update patch name.
  [arguments]: Add skip-python-tests phase.
  Add fpc-external-tool phase.
  Add use-dumppdf-py phase.
  [native-inputs]: Add fpc.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/diffoscope.scm38
-rw-r--r--gnu/packages/patches/diffoscope-fix-llvm-test.patch (renamed from gnu/packages/patches/diffoscope-fix-test_item3_deflate_llvm_bitcode.patch)0
2 files changed, 35 insertions, 3 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f96577ce6d..cb4c766f4e 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -49,6 +49,7 @@
   #:use-module (gnu packages mono)
   #:use-module (gnu packages ocaml)
   #:use-module (gnu packages package-management)
+  #:use-module (gnu packages pascal)
   #:use-module (gnu packages patchutils)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages python-web)
@@ -72,7 +73,7 @@
 (define-public diffoscope
   (package
     (name "diffoscope")
-    (version "186")
+    (version "188")
     (source
      (origin
        (method git-fetch)
@@ -81,9 +82,9 @@
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1qlll5jn76ci5jy915v2kvyngfyycwylxpbdylffzaninvdy3dav"))
+        (base32 "1byd28ihni5g0ikjjcsq68smj1rw33vv9z0cymqa4ds670c77yvn"))
        (patches
-        (search-patches "diffoscope-fix-test_item3_deflate_llvm_bitcode.patch"))))
+        (search-patches "diffoscope-fix-llvm-test.patch"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -108,6 +109,36 @@
                          (string-append "['" (which "stat") "',"))
                         (("\\['getfacl',")
                          (string-append "['" (which "getfacl") "',")))))
+                  (add-after 'unpack 'skip-python-tests
+                    (lambda _
+                      ;; Python tests appear to assume python 3.9, remove
+                      ;; phase when python is upgraded
+                      (substitute* "tests/comparators/test_python.py"
+                        (("def test_identification")
+                         "def skip_test_identification"))
+                      (substitute* "tests/comparators/test_python.py"
+                        (("def test_diff")
+                         "def skip_test_diff"))))
+                  (add-after 'unpack 'use-dumppdf-py
+                    ;; python-pdfminer-six ships "dumppdf" as "dumppdf.py"
+                    ;; https://salsa.debian.org/reproducible-builds/diffoscope/-/issues/283
+                    ;; Fixed upstream, remove this phase when updating to
+                    ;; diffoscope 189
+                    (lambda _
+                      (substitute* "diffoscope/comparators/pdf.py"
+                        (("dumppdf") "dumppdf.py"))
+                      (substitute* "diffoscope/external_tools.py"
+                        (("dumppdf") "dumppdf.py"))
+                      (substitute* "diffoscope/external_tools.py"
+                        (("'debian': 'python3-pdfminer'")
+                         "'debian': 'python3-pdfminer', 'guix': 'python-pdfminer-six'"))))
+                  (add-after 'unpack 'fpc-external-tool
+                    ;; Fixed upstream, remove this phase when updating to
+                    ;; diffoscope 189
+                    (lambda _
+                      (substitute* "diffoscope/external_tools.py"
+                        (("'debian': 'fp-utils'")
+                         "'debian': 'fp-utils', 'guix': 'fpc'"))))
                   (add-after 'build 'build-man-page
                     (lambda* (#:key (make-flags '()) #:allow-other-keys)
                       (apply invoke "make" "-C" "doc" make-flags)))
@@ -182,6 +213,7 @@
                      ("dtc" ,dtc)
                      ("e2fsprogs" ,e2fsprogs)
                      ("ffmpeg" ,ffmpeg)
+                     ("fpc" ,fpc)
                      ("gettext" ,gettext-minimal)
                      ("ghostscript" ,ghostscript)
                      ("giflib:bin" ,giflib "bin")
diff --git a/gnu/packages/patches/diffoscope-fix-test_item3_deflate_llvm_bitcode.patch b/gnu/packages/patches/diffoscope-fix-llvm-test.patch
index 45e496a128..45e496a128 100644
--- a/gnu/packages/patches/diffoscope-fix-test_item3_deflate_llvm_bitcode.patch
+++ b/gnu/packages/patches/diffoscope-fix-llvm-test.patch