summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2022-11-20 09:24:00 -0800
committerChristopher Baines <mail@cbaines.net>2022-11-24 09:44:25 +0000
commitb0307b7c123f741fa14c8a7b87d6427ccb3316ac (patch)
tree42323c6edadb05baed61bd64998f0796b020a78f /gnu/packages
parent58eef1a258f41e263007aa3a6ab387601e7fe0ae (diff)
downloadguix-b0307b7c123f741fa14c8a7b87d6427ccb3316ac.tar.gz
gnu: Add go-github-com-hebcal-gematriya.
* gnu/packages/golang.scm (go-github-com-hebcal-gematriya): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bea58e9e31..57ed50157a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2511,6 +2511,32 @@ web framework
 sunset times from geographical coordinates and a date.")
       (license license:expat))))
 
+(define-public go-github-com-hebcal-gematriya
+  (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
+        (revision "0"))
+    (package
+      (name "go-github-com-hebcal-gematriya")
+      (version (git-version "1.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hebcal/gematriya")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xmnb2i80dy380yv8c4pd04bbyqgbc7c40p8hz1vqj2lhbm6jabf"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "github.com/hebcal/gematriya"))
+      (home-page "https://github.com/hebcal/gematriya")
+      (synopsis "Print numbers as Hebrew letters in Go")
+      (description
+       "This package provides a Go library for printing numbers as
+Hebrew letters.")
+      (license license:bsd-2))))
+
 (define-public go-github-com-aws-sdk
   (package
     (name "go-github-com-aws-sdk")