summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:27:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:50 +0200
commitc65bad4759b5c9d7af659936dfe35de0e9e0582f (patch)
treeac4e001adf99bf51f667d78dd40035f8b086a09a /gnu/packages
parent721b2a46dde6bacab60a012766ddb8deb328f037 (diff)
downloadguix-c65bad4759b5c9d7af659936dfe35de0e9e0582f.tar.gz
gnu: Add texlive-kvmap.
* gnu/packages/tex.scm (texlive-kvmap): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b6c6505c99..ee0b395659 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4293,6 +4293,28 @@ using TikZ.  Though similar to the @code{karnaugh} macros, it provides
 a key-value system to customize Karnaugh maps and a proper LaTeX package.")
     (license license:lppl1.2+)))
 
+(define-public texlive-kvmap
+  (package
+    (name "texlive-kvmap")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/kvmap/" "source/latex/kvmap/"
+                   "tex/latex/kvmap/")
+             (base32
+              "04sjs8r2ijd0rdx5d13p6pwnwnwd0rgzx894j3cqfi29y860c7yr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-amsmath texlive-l3experimental
+                             texlive-pgf))
+    (home-page "https://ctan.org/pkg/kvmap")
+    (synopsis "Create Karnaugh maps with LaTeX")
+    (description
+     "This LaTeX package allows the creation of (even large) Karnaugh maps.
+It provides a tabular-like input syntax and support for drawing bundles
+(implicants) around adjacent values.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")