summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-03 13:31:19 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:04 -0500
commitcbe8f0cdd6710c7eaff196a5951a915e2389b8ff (patch)
treeecc21d3b83c41f2e138b07a13982d797bb0bfbe2 /gnu/packages
parentb902eb1ccdcaf4616fea00ae6e1ed19235c5e169 (diff)
downloadguix-cbe8f0cdd6710c7eaff196a5951a915e2389b8ff.tar.gz
gnu: Add Test-utf8.
* gnu/packages/perl.scm (perl-test-utf8): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f5b44ccaf7..fe6c23201d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4043,6 +4043,27 @@ STDOUT, STDERR, warnings, exceptions, would-be exit codes, and return values
 from boxed blocks of test code.")
     (license (package-license perl))))
 
+(define-public perl-test-utf8
+  (package
+    (name "perl-test-utf8")
+    (version "1.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MA/MARKF/"
+                           "Test-utf8-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0yhvf735v334qqvp9zg7i66qyk6r4cbk5s2psv93d3fdd4bindzg"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Test-utf8")
+    (synopsis "UTF-8 testing in Perl")
+    (description "This module is a collection of tests useful for dealing with
+UTF-8 strings in Perl.  This module has two types of tests: The validity tests
+check if a string is valid and not corrupt, whereas the characteristics tests
+will check that string has a given set of characteristics.")
+    (license (package-license perl))))
+
 (define-public perl-test-warn
   (package
     (name "perl-test-warn")