summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 18:58:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 19:08:31 +0200
commitd0776ff44c0f18564cc7e4fafd45fb04634015d4 (patch)
tree8e9631c56b79741140c43668dcfa4ba5c84956a4 /gnu/packages
parentacc671acf78bfe91319b77b12658420d8f15f08c (diff)
downloadguix-d0776ff44c0f18564cc7e4fafd45fb04634015d4.tar.gz
gnu: Add texlive-collection-langgreek.
* gnu/packages/tex.scm (texlive-collection-langgreek): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47630066b4..e0c8e9dbbd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -38564,6 +38564,44 @@ simply on the size of the support.")
     (description "This collection provides support packages for German.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-collection-langgreek
+  (package
+    (name "texlive-collection-langgreek")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-babel-greek
+           texlive-begingreek
+           texlive-betababel
+           texlive-cbfonts
+           texlive-cbfonts-fd
+           texlive-collection-basic
+           texlive-gfsbaskerville
+           texlive-gfsporson
+           texlive-greek-fontenc
+           texlive-greek-inputenc
+           texlive-greekdates
+           texlive-greektex
+           texlive-greektonoi
+           texlive-hyphen-complete
+           texlive-ibycus-babel
+           texlive-ibygrk
+           texlive-kerkis
+           texlive-levy
+           texlive-lgreek
+           texlive-lgrmath
+           texlive-mkgrkindex
+           texlive-talos
+           texlive-teubner
+           texlive-xgreek
+           texlive-yannisgr))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Support for Greek")
+    (description "This collection provides support for Greek.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 (define-public texlive-collection-langitalian
   (package
     (name "texlive-collection-langitalian")