summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-20 23:22:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-21 00:02:48 +0100
commitd14c770d55225ea485d79466cd01fe3912fea3d6 (patch)
treea7d3375ad5fb522b3cf251383069630095a3c15a /gnu/packages
parent8b672b2c48164c78731ae142ae4761d91666bdec (diff)
downloadguix-d14c770d55225ea485d79466cd01fe3912fea3d6.tar.gz
gnu: Add r-insight.
* gnu/packages/cran.scm (r-insight): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eac6293fc9..fd99e5cf39 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5811,6 +5811,32 @@ from the @code{stats} package, as well as numerous other model classes from
 other add-on packages.")
     (license license:expat)))
 
+(define-public r-insight
+  (package
+    (name "r-insight")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "insight" version))
+       (sha256
+        (base32
+         "0cy00j4m9r690hrjdmv8wzwn8mbnkjd3g527nvsmid64h9jgks5f"))))
+    (build-system r-build-system)
+    (home-page "https://easystats.github.io/insight/")
+    (synopsis "Easy access to model information for various model objects")
+    (description
+     "This package provides a tool to provide an easy, intuitive and
+consistent access to information contained in various R models, like model
+formulas, model terms, information about random effects, data that was used to
+fit the model or data from response variables.  The package mainly revolves
+around two types of functions: Functions that find (the names of) information,
+starting with @code{find_}, and functions that get the underlying data,
+starting with @code{get_}.  The package has a consistent syntax and works with
+many different model objects, where otherwise functions to access these
+information are missing.")
+    (license license:gpl3)))
+
 (define-public r-sjlabelled
   (package
     (name "r-sjlabelled")