summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:29:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:54 +0200
commitda3005f87491075827b2506247aa27b0011ef67b (patch)
tree5b3c2cec7821ceb129c91d54d46a65d76a7114bd /gnu/packages
parent781ce5c8afdea292d9dfc179868ffb1fdddef22b (diff)
downloadguix-da3005f87491075827b2506247aa27b0011ef67b.tar.gz
gnu: Add texlive-mathcomp.
* gnu/packages/tex.scm (texlive-mathcomp): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82895b6ece..140deb7f17 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4498,6 +4498,27 @@ The primary objective of this package is to be used together with the
 knowledge package for a proper handling of mathematical notations.")
     (license license:lppl1.3+)))
 
+(define-public texlive-mathcomp
+  (package
+    (name "texlive-mathcomp")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mathcomp/"
+                   "source/latex/mathcomp/"
+                   "tex/latex/mathcomp/")
+             (base32
+              "0a7y6r9ikasr9v48671ij40z31j0mxiliy1k3yg3ldbiggrjh07i")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mathcomp")
+    (synopsis "Text symbols in maths mode")
+    (description
+     "This package provides a package which provides access to some
+interesting characters of the Text Companion fonts (TS1 encoding) in maths
+mode.")
+    (license license:lppl)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")