summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 19:32:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:37 +0000
commite4fcdc52bb056354cc08fb9b9be5dd8e4236b26d (patch)
tree5b133b0e729f86646aea2df57ea3562a090f0443 /gnu/packages
parent14abf6e19e5c24fa690a443f5467e7f0b6eafcc5 (diff)
downloadguix-e4fcdc52bb056354cc08fb9b9be5dd8e4236b26d.tar.gz
gnu: go-github-com-lithammer-fuzzysearch: Enable tests.
* gnu/packages/golang.scm (go-github-com-lithammer-fuzzysearch): Enable tests.

Change-Id: Ib040db7321d33e2dfdefa37b59bcc095ea96dbb2
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 00dde61f2c..f0753d97ed 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8250,12 +8250,17 @@ terminal.")
     (build-system go-build-system)
     (propagated-inputs (list go-golang-org-x-text))
     (arguments
-     (list #:import-path "github.com/lithammer/fuzzysearch"
-           #:tests? #f ; Source-only package.
-           #:phases
-           #~(modify-phases %standard-phases
-               ;; Source-only package.
-               (delete 'build))))
+     (list
+      #:import-path "github.com/lithammer/fuzzysearch"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Replace when go-build-system supports nested path.
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key import-path tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
     (home-page "https://github.com/lithammer/fuzzysearch")
     (synopsis "Tiny and fast fuzzy search in Go")
     (description