summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:26:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:16 +0200
commitebade8f9964498e8d23739680ae466debe968ea9 (patch)
tree0675509593321309f555d5e68ea9bdd96a126412 /gnu/packages
parente0e3d45f5c0be296b8c9cb6d080ef37654ef4fa7 (diff)
downloadguix-ebade8f9964498e8d23739680ae466debe968ea9.tar.gz
gnu: Add texlive-ibarra.
* gnu/packages/tex.scm (texlive-ibarra): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a024a5c59e..c8cf1b9184 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14624,6 +14624,32 @@ uses by default the Arabic fonts Scheherazade and ALM fixed, the only
 monospaced Arabic font.  The package only works with LuaLaTeX or XeLaTeX.")
     (license license:lppl1.3c)))
 
+(define-public texlive-ibarra
+  (package
+    (name "texlive-ibarra")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/ibarra/"
+                   "fonts/enc/dvips/ibarra/"
+                   "fonts/map/dvips/ibarra/"
+                   "fonts/opentype/public/ibarra/"
+                   "fonts/tfm/public/ibarra/"
+                   "fonts/type1/public/ibarra/"
+                   "fonts/vf/public/ibarra/"
+                   "tex/latex/ibarra/")
+             (base32
+              "0gfvrb1dm2hw8j10l93xv0rrd7kar2009lycsvmw66m1a31c0yd9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ibarra")
+    (synopsis "LaTeX support for the Ibarra Real Nova family of fonts")
+    (description
+     "The Ibarra Real Nova is a revival of a typeface designed by Geronimo Gil
+for the publication of @emph{Don Quixote} for the Real Academia de la Lengua
+in 1780.")
+    (license (list license:silofl1.1 license:lppl))))
+
 (define-public texlive-ibrackets
   (package
     (name "texlive-ibrackets")