summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 15:51:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:59 +0200
commitf534b1c5546af17c34ea571648bd11d35d2ebb7f (patch)
tree2223bfc24ab905d0c0785c504ff69bb029403429 /gnu/packages
parent5cd8f451eac6d6254d4ae527bdcd715730228689 (diff)
downloadguix-f534b1c5546af17c34ea571648bd11d35d2ebb7f.tar.gz
gnu: rust-base16ct: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-base16ct-0.2, rust-base16ct-0.1):
Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: I1e5c5e033510140ed724557ab79e8660433fe45c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-crypto.scm34
-rw-r--r--gnu/packages/crates-io.scm34
2 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 0ccac7d587..58610140ec 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -555,6 +555,40 @@ This package is deprecated and was replaced by the @code{aes} crate.")
 for the Argon2d, Argon2i, and Argon2id algorithmic variants.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-base16ct-0.2
+  (package
+    (name "rust-base16ct")
+    (version "0.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "base16ct" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1kylrjhdzk7qpknrvlphw8ywdnvvg39dizw9622w3wk5xba04zsc"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/RustCrypto/formats/tree/master/base16ct")
+    (synopsis "Rust implementation of Base16 a.k.a hexadecimal")
+    (description
+     "This package provides a pure Rust implementation of Base16 a.k.a
+hexadecimal (RFC 4648) which avoids any usages of data-dependent branches/LUTs
+and thereby provides portable \"best effort\" constant-time operation and
+embedded-friendly no_std support.")
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-base16ct-0.1
+  (package
+    (inherit rust-base16ct-0.2)
+    (name "rust-base16ct")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "base16ct" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1klccxr7igf73wpi0x3asjd8n0xjg0v6a7vxgvfk5ybvgh1hd6il"))))))
+
 (define-public rust-blake2-0.10
   (package
     (name "rust-blake2")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 52014cf7b9..47956960cc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5106,40 +5106,6 @@ systems.")
 API for Rust.")
     (license (list license:expat license:x11 license:asl2.0))))
 
-(define-public rust-base16ct-0.2
-  (package
-    (name "rust-base16ct")
-    (version "0.2.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "base16ct" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1kylrjhdzk7qpknrvlphw8ywdnvvg39dizw9622w3wk5xba04zsc"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/RustCrypto/formats/tree/master/base16ct")
-    (synopsis "Rust implementation of Base16 a.k.a hexadecimal")
-    (description
-     "This package provides a pure Rust implementation of Base16 a.k.a
-hexadecimal (RFC 4648) which avoids any usages of data-dependent branches/LUTs
-and thereby provides portable \"best effort\" constant-time operation and
-embedded-friendly no_std support.")
-    (license (list license:asl2.0 license:expat))))
-
-(define-public rust-base16ct-0.1
-  (package
-    (inherit rust-base16ct-0.2)
-    (name "rust-base16ct")
-    (version "0.1.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "base16ct" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1klccxr7igf73wpi0x3asjd8n0xjg0v6a7vxgvfk5ybvgh1hd6il"))))))
-
 (define-public rust-base32-0.4
   (package
     (name "rust-base32")