summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 19:06:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 19:06:44 +0100
commitfac2e1a110ed4b8cbbb74cd4cea476347ec7e44c (patch)
treee0f214a3f3b36d1e209cf32a1b5fe6e2c5b34487 /gnu/packages
parent3fb78caa55150cfeb85dbbb15b25e077b8f84d9a (diff)
downloadguix-fac2e1a110ed4b8cbbb74cd4cea476347ec7e44c.tar.gz
gnu: Add r-collections.
* gnu/packages/cran.scm (r-collections): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1ac9e4b033..b316a3c05f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -156,6 +156,25 @@ can limit either their total size or the age of the oldest object (or both),
 automatically pruning objects to maintain the constraints.")
     (license license:expat)))
 
+(define-public r-collections
+  (package
+    (name "r-collections")
+    (version "0.3.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "collections" version))
+       (sha256
+        (base32 "053ig88pva78wxxwya3v7cz853k563dkpgxrf2xvd0l0d9fanxmz"))))
+    (properties `((upstream-name . "collections")))
+    (build-system r-build-system)
+    (home-page "https://github.com/randy3k/collections")
+    (synopsis "High performance container data types")
+    (description
+     "This package provides high performance container data types such as
+queues, stacks, deques, dicts and ordered dicts.")
+    (license license:expat)))
+
 (define-public r-curry
   (package
     (name "r-curry")