summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-06-30 09:15:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-06-30 09:15:29 +0300
commitfc15524d371394e538d3e9635ba05aa85c9c7d2c (patch)
treefe49bc48423985acf2949544bd1f7d9e16f71c37 /gnu/packages
parentf3689976da3d23b0a73cf1733da04add5e1035ee (diff)
downloadguix-fc15524d371394e538d3e9635ba05aa85c9c7d2c.tar.gz
gnu: clang-15: Fix building on i686-linux.
* gnu/packages/llvm.scm (clang-from-llvm)[arguments]: When building for
i686-linux on clang 15 or newer delete the 'make-dynamic-linker-cache
phase.

Change-Id: I0c8c273ce8eca100a97a9a64a4524558acd7cfbd
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/llvm.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index e87b88c1e3..7aab2ae8c3 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -7,7 +7,7 @@
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2018–2022 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2021-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
@@ -376,6 +376,11 @@ until LLVM/Clang 14."
                                   "add_subdirectory(${LLVM_THIRD_PARTY_DIR}/uni\
 ttest third-party/unittest)\n" line))))))
                         '())
+                  ;; The build daemon goes OOM on i686-linux on this phase.
+                  ,@(if (and (version>=? version "15")
+                             (target-x86-32?))
+                        '((delete 'make-dynamic-linker-cache))
+                        '())
                   ;; Awkwardly, multiple phases added after the same phase,
                   ;; e.g. unpack, get applied in the reverse order.  In other
                   ;; words, adding 'change-directory last means it occurs