summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTakeV <takev@disroot.org>2024-04-03 18:21:24 -0400
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 23:27:36 +0100
commitfd116510b2f4fd731bb775affd2b03329982b65b (patch)
tree17155b2a93c382134deeb555712699c8b5f114ac /gnu/packages
parent090fd6a4da1a3fe2e24b6e23ee030c010ba0db16 (diff)
downloadguix-fd116510b2f4fd731bb775affd2b03329982b65b.tar.gz
gnu: Add python-iterable-io.
* gnu/packages/python-xyz.scm (python-iterable-io): New variable.

Change-Id: Icd4b10e27b5f4963fd3e3ea516676e84b3c5ecd4
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f2ea90ad09..190284f4d9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -151,6 +151,7 @@
 ;;; Copyright © 2024 Ian Eure <ian@retrospec.tv>
 ;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
 ;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2024 TakeV <takev@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34998,6 +34999,28 @@ sources.  For example, it allows you to have all your casting and
 parsing rules in a single place.")
     (license license:bsd-3)))
 
+(define-public python-iterable-io
+  (package
+    (name "python-iterable-io")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "iterable-io" version))
+       (sha256
+        (base32 "0g4cn522n4dv6ly8pwf97dc62rr4f7my38v0bh6vmac7jmrip7pv"))))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/pR0Ps/iterable-io")
+    (synopsis "Adapt generators and other iterables to a file-like interface")
+    (description
+     "@code{iterable-io} is a small Python library that provides an adapter so
+that it's possible to read from
+@url{https://docs.python.org/3/glossary.html#term-iterable,iterable} objects
+in the same way as
+@url{https://docs.python.org/3/glossary.html#term-file-object,file-like}
+objects.")
+    (license license:lgpl3)))
+
 (define-public python-iteround
   (package
     (name "python-iteround")