summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:29:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:02 +0200
commitfe5b3e306eb5416b72bdc9d7dd6cb61a4e11f1ca (patch)
tree0ba53da065c44515295f1c1976513a8da6b53993 /gnu/packages
parent012c1d9b4289aba262db5d06c8e68a4729c72db3 (diff)
downloadguix-fe5b3e306eb5416b72bdc9d7dd6cb61a4e11f1ca.tar.gz
gnu: rust-p384-0.13: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-p384-0.13): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: I6ff1edbb1ad72a8c536192abf313652605d3f86b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-crypto.scm36
-rw-r--r--gnu/packages/crates-io.scm36
2 files changed, 36 insertions, 36 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 264b2d26a9..99c7e353fe 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2333,6 +2333,42 @@ secp256r1, prime256v1) elliptic curve as defined in SP 800-186, with support for
 ECDH, ECDSA signing/verification, and general purpose curve arithmetic.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-p384-0.13
+  (package
+    (name "rust-p384")
+    (version "0.13.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "p384" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "02cjlxdvxwvhmnckqnydqpvrwhf5raj67q300d66m7y6pi8nyy3h"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ecdsa" ,rust-ecdsa-0.16)
+        ("rust-elliptic-curve" ,rust-elliptic-curve-0.13)
+        ("rust-hex-literal" ,rust-hex-literal-0.3)
+        ("rust-primeorder" ,rust-primeorder-0.13)
+        ("rust-serdect" ,rust-serdect-0.2)
+        ("rust-sha2" ,rust-sha2-0.10))
+       #:cargo-development-inputs
+       (("rust-blobby" ,rust-blobby-0.3)
+        ("rust-criterion" ,rust-criterion-0.4)
+        ("rust-ecdsa" ,rust-ecdsa-0.16)
+        ("rust-hex-literal" ,rust-hex-literal-0.3)
+        ("rust-proptest" ,rust-proptest-1)
+        ("rust-rand-core" ,rust-rand-core-0.6))))
+    (home-page
+     "https://github.com/RustCrypto/elliptic-curves/tree/master/p384")
+    (synopsis "Pure Rust implementation of the NIST P-384 elliptic curve")
+    (description
+     "This package provides a pure Rust implementation of the NIST P-384 (a.k.a.
+secp384r1) elliptic curve as defined in SP 800-186 with support for ECDH, ECDSA
+signing/verification, and general purpose curve arithmetic support.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-pbkdf2-0.12
   (package
     (name "rust-pbkdf2")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e1cee42e60..9cc40b58ab 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45528,42 +45528,6 @@ normally prevent moving a type that has been borrowed from.")
      (list #:cargo-inputs
            `(("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))))
 
-(define-public rust-p384-0.13
-  (package
-    (name "rust-p384")
-    (version "0.13.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "p384" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "02cjlxdvxwvhmnckqnydqpvrwhf5raj67q300d66m7y6pi8nyy3h"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-ecdsa" ,rust-ecdsa-0.16)
-        ("rust-elliptic-curve" ,rust-elliptic-curve-0.13)
-        ("rust-hex-literal" ,rust-hex-literal-0.3)
-        ("rust-primeorder" ,rust-primeorder-0.13)
-        ("rust-serdect" ,rust-serdect-0.2)
-        ("rust-sha2" ,rust-sha2-0.10))
-       #:cargo-development-inputs
-       (("rust-blobby" ,rust-blobby-0.3)
-        ("rust-criterion" ,rust-criterion-0.4)
-        ("rust-ecdsa" ,rust-ecdsa-0.16)
-        ("rust-hex-literal" ,rust-hex-literal-0.3)
-        ("rust-proptest" ,rust-proptest-1)
-        ("rust-rand-core" ,rust-rand-core-0.6))))
-    (home-page
-     "https://github.com/RustCrypto/elliptic-curves/tree/master/p384")
-    (synopsis "Pure Rust implementation of the NIST P-384 elliptic curve")
-    (description
-     "This package provides a pure Rust implementation of the NIST P-384 (a.k.a.
-secp384r1) elliptic curve as defined in SP 800-186 with support for ECDH, ECDSA
-signing/verification, and general purpose curve arithmetic support.")
-    (license (list license:asl2.0 license:expat))))
-
 (define-public rust-packed-simd-0.3
   (package
     (name "rust-packed-simd")