summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-06 14:13:09 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:14 +0200
commitfef71dbc9d28cccda627922d036ebf70844dbc84 (patch)
treefa844703ff5e70ab4bc8ed058a70c5ec3ec7f6c8 /gnu/packages
parent75c07ef5199179cba554a733048d21649f6c0d15 (diff)
downloadguix-fef71dbc9d28cccda627922d036ebf70844dbc84.tar.gz
gnu: ghc-hashtables: Update to 1.2.3.1.
* gnu/packages/haskell.scm (ghc-hashtables): Update to 1.2.3.1.
[arguments]: Remove unneeded "--allow-newer" configure flag.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bfc061c107..c4dbbc7d75 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7804,7 +7804,7 @@ Haskell, using gnuplot for rendering.")
 (define-public ghc-hashtables
   (package
     (name "ghc-hashtables")
-    (version "1.2.1.0")
+    (version "1.2.3.1")
     (source
      (origin
        (method url-fetch)
@@ -7812,10 +7812,8 @@ Haskell, using gnuplot for rendering.")
              "https://hackage.haskell.org/package/hashtables/hashtables-"
              version ".tar.gz"))
        (sha256
-        (base32 "1b6w9xznk42732vpd8ili60k12yq190xnajgga0iwbdpyg424lgg"))))
+        (base32 "1giw9caajr07slf09j7zry9b0kvm4yj9q78zy1mawzi6gk3wglcg"))))
     (build-system haskell-build-system)
-    (arguments
-     `(#:configure-flags (list "--allow-newer=vector")))
     (inputs
      `(("ghc-hashable" ,ghc-hashable)
        ("ghc-primitive" ,ghc-primitive)