summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-15 11:46:23 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-15 11:46:23 +0000
commit078934bdd4556cf19da728bd49608d7792b533f1 (patch)
treed367821c62e4863fd1529e9b21cf9fa40e39b736 /gnu/packages
parent373d2099c9def2c21ea6528f0954b8ba63176f8f (diff)
downloadguix-078934bdd4556cf19da728bd49608d7792b533f1.tar.gz
gnu: python-scipy: Run tests conditionally.
* gnu/packages/python-science.scm (python-scipy)[arguments]: Respect TESTS? in
'CHECK phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b68a2838fc..ef7ae2b0a1 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -160,11 +160,12 @@ atlas_libs = openblas
          ;; within the source directory.
          (delete 'check)
          (add-after 'install 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (with-directory-excursion "/tmp"
-               (invoke "python" "-c"
-                       "import scipy; scipy.test(verbose=2)")))))))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (with-directory-excursion "/tmp"
+                 (invoke "python" "-c"
+                         "import scipy; scipy.test(verbose=2)"))))))))
     (home-page "https://www.scipy.org/")
     (synopsis "The Scipy library provides efficient numerical routines")
     (description "The SciPy library is one of the core packages that make up