summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-21 22:09:21 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:36:05 +0200
commit0c8a51c7d28befa49e596421de22c0b4fef100f0 (patch)
tree2930e723c394e31cf6f990d823b0c900c45156ff /gnu/packages
parentaa13c5657d4f8b5dd52beda88a9a8ccc59ebca86 (diff)
downloadguix-0c8a51c7d28befa49e596421de22c0b4fef100f0.tar.gz
gnu: cogl: Fix build with Mesa 20.
* gnu/packages/gnome.scm (cogl)[arguments]: Add phase to adjust header includes.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 938efbcdf3..e0e1ed1804 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4486,6 +4486,17 @@ throughout GNOME for API documentation).")
                                               "/lib/libGL.so"))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-build-with-mesa-20
+           (lambda _
+             ;; Work around a problem with Mesa 20 where some macros used by
+             ;; Cogl went missing from eglext.h.  This can likely be removed
+             ;; for newer versions of Cogl or Mesa.
+             ;; https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/19
+             (substitute* '("configure"
+                            "cogl/winsys/cogl-winsys-egl-kms.c")
+               (("#include <EGL/eglext.h>" all)
+                (string-append all "\n#include <EGL/eglmesaext.h>\n")))
+             #t))
          (add-before 'check 'start-xorg-server
                      (lambda* (#:key tests? inputs #:allow-other-keys)
                        (if tests?