summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-01 09:45:20 -0500
committer宋文武 <iyzsong@member.fsf.org>2020-12-06 18:35:12 +0800
commit74e3c37ae0cf8d614c78d6ff0c9da1425025e503 (patch)
tree8915a4485b6832192e30c5153614510559955af7 /gnu/packages
parent4fcff5909135e9e7d56601f07ac612fa67b66d52 (diff)
downloadguix-74e3c37ae0cf8d614c78d6ff0c9da1425025e503.tar.gz
gnu: knot-resolver: Move manual, examples to separate "doc" output
* gnu/packages/dns.scm (knot-resolver)[outputs]: Add "doc" output.
[arguments]<phases>: Add "move-doc" phase, which moves the manual (in both
HTML and Info formats) and example configuration files to the "doc" output.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dns.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 85196e79c2..d4179024d8 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -949,6 +949,7 @@ synthesis, and on-the-fly re-configuration.")
                 (search-patches
                  "knot-resolver-fix-map-command-on-32-bit.patch"))))
     (build-system meson-build-system)
+    (outputs '("out" "doc"))
     (arguments
      '(#:configure-flags '("-Ddoc=enabled")
        #:phases
@@ -963,6 +964,20 @@ synthesis, and on-the-fly re-configuration.")
          (add-after 'build 'build-doc
            (lambda _
              (invoke "ninja" "doc")))
+         (add-after 'install 'move-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Move the manual and the example configuration files to the
+             ;; "doc" output.
+             (let ((out (assoc-ref outputs "out"))
+                   (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share/doc/knot-resolver"))
+               (for-each
+                (lambda (dir)
+                  (rename-file (string-append out "/share/" dir)
+                               (string-append doc "/share/" dir)))
+                '("doc/knot-resolver/examples"
+                  "doc/knot-resolver/html"
+                  "info")))))
          (add-after 'install 'wrap-binary
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))