summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:16 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 00:06:25 +0100
commitb8175e3aa287c3ff239f3c7ae8fb606f7a900d06 (patch)
treee30fee53996e2d28b5be302808671750b7e3dcd2 /gnu/packages
parentd2a65a34d5326397b89e9dc74fb779fd54e55c65 (diff)
downloadguix-b8175e3aa287c3ff239f3c7ae8fb606f7a900d06.tar.gz
gnu: Remove python2-amqp.
* gnu/packages/python-xyz.scm (python2-amqp): Remove variable.
(python-amqp)[properties]: Remove.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 348dd992ed..f2479f64dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13952,18 +13952,7 @@ and provides a uniform API regardless of which JSON implementation is used.")
      "This is a fork of amqplib which was originally written by Barry Pederson.
 It is maintained by the Celery project, and used by kombu as a pure python
 alternative when librabbitmq is not available.")
-    (license license:lgpl2.1+)
-    (properties `((python2-variant . ,(delay python2-amqp))))))
-
-(define-public python2-amqp
-  (let ((amqp (package-with-python2
-               (strip-python2-variant python-amqp))))
-    (package/inherit amqp
-      (arguments `(;; Tries to run coverage tests with nose-cover3, which seems
-                   ;; unmaintained.  Weirdly, does not do this on the python 3
-                   ;; version?
-                   #:tests? #f
-                   ,@(package-arguments amqp))))))
+    (license license:lgpl2.1+)))
 
 (define-public python-txamqp
   (package