summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 21:42:15 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commitb8efe89eb4f569d3140e3feb398eb2f78b8987b6 (patch)
tree7a9432db2c5646170164d776ed1a1e0bfcb42c4e /gnu/packages
parent8bdc4c15474e226d1bc7e07ce6f4228a7b3317a5 (diff)
downloadguix-b8efe89eb4f569d3140e3feb398eb2f78b8987b6.tar.gz
gnu: python-tempora: Switch to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-tempora)[build-system]: Switch to
PYPROJECT-BUILD-SYSTEM.
[arguments]: Add #:test-flags.  Remove #:phases.
[native-inputs]: Remove PYTHON-PYPA-BUILD.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 5 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 034781c2fd..922eacdc51 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21390,30 +21390,13 @@ particularly convenient for use in tests.")
        (uri (pypi-uri "tempora" version))
        (sha256
         (base32 "09wirlk5vmxlhl9rnxp7g5qz2nsd6b0gnzk5fczbz0s8lsbz386b"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          ;; XXX: PEP 517 manual build copied from python-isort.
-          (replace 'build
-            (lambda _
-              (setenv "SOURCE_DATE_EPOCH" "315532800")
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl))))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                ;; Do not test the myproject.toml build as it tries to pull
-                ;; dependencies from the Internet.
-                (invoke "pytest" "-k" "not project")))))))
+     ;; Do not test the myproject.toml build as it tries to pull
+     ;; dependencies from the Internet.
+     (list #:test-flags #~'("-vv" "-k" "not project")))
     (native-inputs
-     (list python-pypa-build
-           python-freezegun
+     (list python-freezegun
            python-pytest
            python-pytest-black
            python-pytest-checkdocs