summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-30 17:56:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-30 17:56:05 +0300
commit048e05b7ef568dc5e29df774baaf69f7cc5ddaaa (patch)
tree9b809b640e54ae93d7388676a5d4ca1ed4ff4f0d /gnu/packages
parent7097e98586df3110b80943a88c27804d65f214fa (diff)
downloadguix-048e05b7ef568dc5e29df774baaf69f7cc5ddaaa.tar.gz
gnu: python-cryptography: Downgrade to 3.4.8.
Skip dealing with the rust version for now.

* gnu/packages/python-crypto.scm (python-cryptography): Rename to
python-cryptography-next. Replace with python-cryptography@3.4.8.
(python-cryptography-vectors): Rename to
python-cryptography-vectors-next. Replace with
python-cryptography-vectors@3.4.8.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-crypto.scm40
1 files changed, 37 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c9bc19fbc9..c01692dfce 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -452,7 +452,7 @@ is used by the Requests library to verify HTTPS requests.")
 (define-public python2-certifi
   (package-with-python2 python-certifi))
 
-(define-public python-cryptography-vectors
+(define-public python-cryptography-vectors-next
   (package
     (name "python-cryptography-vectors")
     (version "36.0.1")
@@ -471,7 +471,17 @@ is used by the Requests library to verify HTTPS requests.")
     ;; Distributed under either BSD-3 or ASL2.0
     (license (list license:bsd-3 license:asl2.0))))
 
-(define-public python-cryptography
+(define-public python-cryptography-vectors
+  (package
+    (inherit python-cryptography-vectors-next)
+    (version "3.4.8")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cryptography_vectors" version))
+              (sha256
+               (base32 "1wl0ynh3lzhc6q59g8mybvijmnp195x7fjxlb3h3sgcraw14312c"))))))
+
+(define-public python-cryptography-next
   (package
     (name "python-cryptography")
     (version "36.0.1")
@@ -571,7 +581,7 @@ is used by the Requests library to verify HTTPS requests.")
      (list python-asn1crypto python-cffi python-six python-idna
            python-iso8601))
     (native-inputs
-     (list python-cryptography-vectors
+     (list python-cryptography-vectors-next
            python-hypothesis
            python-pretend
            python-pytz
@@ -592,6 +602,30 @@ message digests and key derivation functions.")
     (license (list license:bsd-3 license:asl2.0))
     (properties `((python2-variant . ,(delay python2-cryptography))))))
 
+(define-public python-cryptography
+  (package
+    (inherit python-cryptography-next)
+    (version "3.4.8")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cryptography" version))
+              (sha256
+               (base32 "072awar70cwfd2hnx0pvp1dkc7gw45mbm3wcyddvxz5frva5xk4l"))))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'set-no-rust
+                 (lambda _
+                   (setenv "CRYPTOGRAPHY_DONT_BUILD_RUST" "1"))))))
+    (inputs (list openssl))
+    (native-inputs
+     (list python-cryptography-vectors
+           python-hypothesis
+           python-pretend
+           python-pytz
+           python-pytest
+           python-setuptools-rust))))
+
 (define-public python2-cryptography-vectors
   (package
     (inherit python-cryptography-vectors)