summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-23 15:38:39 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-03-23 23:29:07 +0100
commit08b9e0ca0be309a732f0784ceee7e436bfd70f15 (patch)
tree097f0493d357ace41115466df744b1e72eba9e7c /gnu/packages
parent4490dff98c6979a77f3982716239b526e0ef1337 (diff)
downloadguix-08b9e0ca0be309a732f0784ceee7e436bfd70f15.tar.gz
gnu: Add java-mxparser.
* gnu/packages/xml.scm (java-mxparser): New variable.

Co-Authored-By: Julien Lepiller <julien@lepiller.eu>
Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xml.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b0b159c5aa..808a847eaf 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2311,6 +2311,48 @@ outputting XML data from Java code.")
 and back again.")
     (license license:bsd-3)))
 
+(define-public java-mxparser
+  (package
+    (name "java-mxparser")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/x-stream/mxparser")
+              (commit (string-append "v-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0i3jrjbz4hgf62fm1ix7nlcmhi4kcv4flqsfvh7a3l2v7nsp5ryb"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "mxparser.jar"
+       #:source-dir "src/main/java"
+       #:test-dir "src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'copy-resources
+           (lambda _
+             (copy-recursively "src/main/resources" "build/classes")
+             #t)))))
+    (propagated-inputs
+     `(("java-xmlpull-api-v1" ,java-xmlpull-api-v1)))
+    (native-inputs
+     `(("java-junit" ,java-junit)))
+    (home-page "https://github.com/x-stream/mxparser")
+    (synopsis "Streaming pull XML parser forked from @code{java-xpp3}")
+    (description "Xml Pull Parser (in short XPP) is a streaming pull XML
+parser and should be used when there is a need to process quickly and
+efficiently all input elements (for example in SOAP processors). This
+package is a stable XmlPull parsing engine that is based on ideas from XPP
+and in particular XPP2 but completely revised and rewritten to take the best
+advantage of JIT JVMs.
+
+MXParser is a fork of xpp3_min 1.1.7 containing only the parser with merged
+changes of the Plexus fork. It is an implementation of the XMLPULL V1 API
+(parser only).")
+    (license (license:non-copyleft "file://LICENSE.txt"))))
+
 (define-public xmlrpc-c
   (package
     (name "xmlrpc-c")