summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-18 20:54:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-18 20:57:24 +0100
commit2cdf16c8c27b24ecfa49cc32b8914bdcc6069ed2 (patch)
treef5159e8993989a2594968a61521460ba49b0d130 /gnu/packages
parent827499e91f95cf69c86d3a5ef668b4a2c0fb349b (diff)
downloadguix-2cdf16c8c27b24ecfa49cc32b8914bdcc6069ed2.tar.gz
gnu: valgrind: Update to 3.13.0.
* gnu/packages/valgrind.scm (valgrind): Update to 3.13.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/valgrind.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 611a9a0558..21556a939d 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,14 +32,14 @@
 (define-public valgrind
   (package
     (name "valgrind")
-    (version "3.12.0")
+    (version "3.13.0")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "http://valgrind.org/downloads/valgrind-"
+              (method url-fetch)
+             (uri (string-append "ftp://sourceware.org/pub/valgrind/valgrind-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "18bnrw9b1d55wi1wnl68n25achsp9w48n51n1xw4fwjjnaal7jk7"))
+               "0fqc3684grrbxwsic1rc5ryxzxmigzjx9p5vf3lxa37h0gpq0rnp"))
              (patches (search-patches "valgrind-enable-arm.patch"))))
     (build-system gnu-build-system)
     (outputs '("doc"                              ;16 MB
@@ -63,9 +64,11 @@
                (mkdir-p dest)
                (rename-file orig dest)
                #t))))))
-    (inputs `(;; GDB is needed to provide a sane default for `--db-command'.
-              ("gdb" ,gdb)))
-    (native-inputs `(("perl" ,perl)))
+    (inputs
+     ;; GDB is needed to provide a sane default for `--db-command'.
+     `(("gdb" ,gdb)))
+    (native-inputs
+     `(("perl" ,perl)))
     (home-page "http://www.valgrind.org/")
     (synopsis "Debugging and profiling tool suite")
     (description