summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:09:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:48 +0200
commit31cb95d2035f9b5a80531dea67b0aae9f9c13d29 (patch)
treecc84e66bad0308ff618272744d316706e61797f3 /gnu/packages
parentf59fe570ef2c18e302523402b98afd0588a8bbd0 (diff)
downloadguix-31cb95d2035f9b5a80531dea67b0aae9f9c13d29.tar.gz
gnu: Add texlive-varisize.
* gnu/packages/tex.scm (texlive-varisize): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2f6750b7a7..ce16ea49ac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3962,6 +3962,25 @@ analytical expansion of sin and cos.")
 barcodes.")
     (license license:lppl)))
 
+(define-public texlive-varisize
+  (package
+    (name "texlive-varisize")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/varisize/" "tex/plain/varisize/")
+             (base32
+              "0nd89zhwyg5z9wcy1lixg3hzcfw83lsilkjhhy9kir0fi9whdbv4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/varisize")
+    (synopsis "Change font size in Plain TeX")
+    (description
+     "This package provides a series of files, each of which defines
+a size-change macro.  Note that @file{10point.tex} is by convention called by
+one of the other files, so that there's always a way back.")
+    (license license:public-domain)))
+
 (define-public texlive-lcdftypetools
   (package
     (name "texlive-lcdftypetools")