summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-17 22:27:39 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-17 23:50:31 +0200
commit515e68782f871a39586ba779137d10c13fa5cde2 (patch)
tree6bf1dc797ede60fbded19a31568534d190c2b3b1 /gnu/packages
parent7df7a74e23583a7cf550af63a4ca5f69203e6da5 (diff)
downloadguix-515e68782f871a39586ba779137d10c13fa5cde2.tar.gz
gnu: Add SCons.
* gnu/packages/python.scm (scons): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b5dbb6b90f..5b37ff6687 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -464,3 +464,29 @@ It uses Accessibility (a11y) technologies to communicate with desktop
 applications. dogtail scripts are written in Python and executed like any
 other Python program.")
     (license gpl2+)))
+
+(define-public scons
+  (package
+    (name "scons")
+    (version "2.1.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/scons/scons-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "07cjn4afb2cljjrd3cr7xf062qq58z8q96f58z6yplhdyqafsfa1"))))
+    (build-system python-build-system)
+    (arguments
+     ;; With Python 3.x, fails to build with a syntax error.
+     `(#:python ,python-2
+       #:tests? #f))                       ; no 'python setup.py test' command
+    (home-page "http://scons.org/")
+    (synopsis "Software construction tool written in Python")
+    (description
+     "SCons is a software construction tool.  Think of SCons as an improved,
+cross-platform substitute for the classic Make utility with integrated
+functionality similar to autoconf/automake and compiler caches such as ccache.
+In short, SCons is an easier, more reliable and faster way to build
+software.")
+    (license x11)))