summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-29 15:58:02 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-29 15:58:53 +0200
commit6c77a5040604ebb7c0196f47520cf5fcc30c2087 (patch)
treecfc781eb8e3a480cd9c19e4a3e8e1f73c3f6ee71 /gnu/packages
parent0ec6b8afd7e7a6c288fbf48c5779f2e0bdaffb55 (diff)
downloadguix-6c77a5040604ebb7c0196f47520cf5fcc30c2087.tar.gz
Revert "gnu: emacs: Strip double wrap."
This reverts commit 0ec6b8afd7e7a6c288fbf48c5779f2e0bdaffb55 that prevents the
load of Emacs packages.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 84c1889617..a338abc774 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -191,17 +191,6 @@
                            (rename-file real wrapper))
                          pdmp pdmp-real))
              #t))
-         (add-after 'glib-or-gtk-wrap 'strip-double-wrap
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
-             ;; twice.  This also fixes a minor issue, where WMs would not be
-             ;; able to track emacs back to emacs.desktop.
-             (with-directory-excursion (assoc-ref outputs "out")
-               (copy-file (string-append
-                           "bin/emacs-"
-                           ,(version-major+minor (package-version emacs)))
-                          "bin/emacs")
-               #t)))
          (add-before 'reset-gzip-timestamps 'make-compressed-files-writable
            ;; The 'reset-gzip-timestamps phase will throw a permission error
            ;; if gzip files aren't writable then.  This phase is needed when