summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-27 14:49:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-27 15:08:37 +0100
commit7184b4b1bd839cd4fd0c9630c050c7854174057d (patch)
tree4d0a639e98498bda398557ab53a674caaf332902 /gnu/packages
parentda6dd842d038aa0761918305953ad92951fb663f (diff)
downloadguix-7184b4b1bd839cd4fd0c9630c050c7854174057d.tar.gz
gnu: Remove now unneeded 'localedef' invocations.
This is a followup to commit b0fd2bd.

* gnu/packages/gawk.scm (gawk)[arguments] <install-locales>: Add comment
  on why we leave this here.
* gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove
  'install-locales' phase.
* gnu/packages/swig.scm (swig)[arguments]: Likewise.
* gnu/packages/python.scm (python-matplotlib): Remove 'LOCPATH' setting
  and 'localedef' invocation.
  (python-scipy): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gawk.scm3
-rw-r--r--gnu/packages/guile.scm11
-rw-r--r--gnu/packages/python.scm12
-rw-r--r--gnu/packages/swig.scm14
4 files changed, 4 insertions, 36 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index e0d3f41ac2..06ecf6a064 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -61,7 +61,8 @@
                  'check 'install-locales
                  (lambda _
                    ;; A bunch of tests require the availability of a UTF-8
-                   ;; locale and otherwise fail.  Give them what they want.
+                   ;; locale and otherwise fail.  Since UTF-8 locales are not
+                   ;; available during bootstrap, create one here.
                    (setenv "LOCPATH" (getcwd))
                    (zero? (system* "localedef" "--no-archive"
                                    "--prefix" (getcwd) "-i" "en_US"
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f71201b553..c29b1213ac 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -261,16 +261,7 @@ many readers as needed).")
                       (("\"libguile-ncurses\"")
                        (format #f "\"~a/lib/libguile-ncurses\""
                                out)))))
-                 (alist-cons-before
-                  'check 'install-locales
-                  (lambda _
-                    ;; One of the tests requires the availability of a UTF-8
-                    ;; locale and otherwise fails.
-                    (setenv "LOCPATH" (getcwd))
-                    (zero? (system* "localedef" "--no-archive"
-                                    "--prefix" (getcwd) "-i" "en_US"
-                                    "-f" "UTF-8" "./en_US.utf8")))
-                  %standard-phases))))
+                 %standard-phases)))
     (home-page "http://www.gnu.org/software/guile-ncurses/")
     (synopsis "Guile bindings to ncurses")
     (description
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0df91d69cb..7569770889 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2251,12 +2251,6 @@ backend = GTK3Agg~%")))))
                   (info (string-append data "/info"))
                   (html (string-append doc "/html")))
              (with-directory-excursion "doc"
-               ;; Install and set UTF-8 locale to avoid an encoding error.
-               (setenv "LOCPATH" (getcwd))
-               (system* "localedef" "--no-archive"
-                        "--prefix" (getcwd) "-i" "en_US"
-                        "-f" "UTF-8" "./en_US.UTF-8")
-               (setenv "LANG" "en_US.UTF-8")
                ;; Produce pdf in 'A4' format.
                (substitute* (find-files "." "conf\\.py")
                  (("latex_paper_size = 'letter'")
@@ -2349,12 +2343,6 @@ toolkits.")
                   (html (string-append doc "/html"))
                   (pyver ,(string-append "PYVER=")))
              (with-directory-excursion "doc"
-               ;; Install and set UTF-8 locale to avoid an encoding error.
-               (setenv "LOCPATH" (getcwd))
-               (system* "localedef" "--no-archive"
-                        "--prefix" (getcwd) "-i" "en_US"
-                        "-f" "UTF-8" "./en_US.UTF-8")
-               (setenv "LANG" "en_US.UTF-8")
                ;; Fix generation of images for mathematical expressions.
                (substitute* (find-files "source" "conf\\.py")
                  (("pngmath_use_preview = True")
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index a978dec681..bd7978da50 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -54,18 +54,6 @@
               ;; The python part probably never worked and does not seem to
               ;; be needed for currently dependent packages.
 ;;               ("python" ,python-wrapper)))
-    (arguments
-     `(#:phases
-       (alist-cons-before
-        'check 'install-locales
-        (lambda _
-          ;; One of the tests requires the availability of a UTF-8
-          ;; locale and otherwise fails.
-          (setenv "LOCPATH" (getcwd))
-          (zero? (system* "localedef" "--no-archive"
-                          "--prefix" (getcwd) "-i" "en_US"
-                          "-f" "UTF-8" "./en_US.utf8")))
-        %standard-phases)))
     (home-page "http://swig.org/")
     (synopsis
      "Interface compiler that connects C/C++ code to higher-level languages")