summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-30 02:22:30 +0100
committerDavid Craven <david@craven.ch>2016-10-30 02:33:58 +0100
commit91ba69358691d25f4bf6dc831c0bb782a1f89e2c (patch)
tree8964aae8224051a2850bb4f55762a6568c7f34be /gnu/packages
parente5e45c067db1ff80d2f1d90cc0fef0420fc22733 (diff)
downloadguix-91ba69358691d25f4bf6dc831c0bb782a1f89e2c.tar.gz
gnu: Add jimtcl.
* gnu/packages/embedded.scm (jimtcl): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/embedded.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 960c0590ba..7c771524db 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -277,3 +277,32 @@ languages are C and C++.")
       (description "libjaylink is a shared library written in C to access
 SEGGER J-Link and compatible devices.")
       (license license:gpl2+))))
+
+(define-public jimtcl
+  (package
+    (name "jimtcl")
+    (version "0.77")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/msteveb/jimtcl"
+                    "/archive/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1cmk3qscqckg70chjyimzxa2qcka4qac0j4wq908kiijp45cax08"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Doesn't use autoconf.
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (zero? (system* "./configure"
+                               (string-append "--prefix=" out)))))))))
+    (home-page "http://jim.tcl.tk")
+    (synopsis "Small footprint Tcl implementation")
+    (description "Jim is a small footprint implementation of the Tcl programming
+language.")
+    (license license:bsd-2)))