summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-15 09:24:01 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:44 +0200
commit95c9898db371022fffd423e5c0563f33e1b27017 (patch)
tree5ca15048953526f2c00db37d529225f7778c69a7 /gnu/packages
parent045cdf867934a30501a84e028f79ede9945f7749 (diff)
downloadguix-95c9898db371022fffd423e5c0563f33e1b27017.tar.gz
gnu: Add rust-seahash-3.0.
* gnu/packages/crates-io.scm (rust-seahash-3.0): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7764b0e70a..53e87ec296 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7023,6 +7023,30 @@ endian-aware Read/Write traits for byte buffers.")
 Pwrite traits from the scroll crate.")
     (license license:expat)))
 
+(define-public rust-seahash-3.0
+  (package
+    (name "rust-seahash")
+    (version "3.0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "seahash" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1pr8ijnxnp68ki4m4740yc5mr01zijf86yx07wbsqzwiyhghdmhq"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page
+     "https://gitlab.redox-os.org/redox-os/seahash")
+    (synopsis
+     "Hash function with proven statistical guarantees")
+    (description
+     "This package provides a blazingly fast, portable hash function with
+proven statistical guarantees.")
+    (license license:expat)))
+
 (define-public rust-security-framework-sys-0.3
   (package
     (name "rust-security-framework-sys")