summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-05-11 20:34:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 09:43:20 +0200
commita070eb7a155835ebdf80ae626ae2e23e052c34fc (patch)
tree1785814cb33fee114c7c00505537da8b0275f29b /gnu/packages
parent9d05f9a9f538061e1fdc5aedb0748d260fcf20f7 (diff)
downloadguix-a070eb7a155835ebdf80ae626ae2e23e052c34fc.tar.gz
gnu: Add python-optparse-pretty.
* gnu/packages/python-xyz.scm (python-optparse-pretty): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4542298252..30769e4966 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -66,7 +66,7 @@
 ;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2019, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2019, 2021-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Riku Viitanen <riku.viitanen@protonmail.com>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
@@ -2794,6 +2794,26 @@ a library.")
     (description "DiskCache is a disk and file backed persistent cache.")
     (license license:asl2.0)))
 
+(define-public python-optparse-pretty
+  (package
+    (name "python-optparse-pretty")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "optparse-pretty" version))
+       (sha256
+        (base32 "1920wbh2b7a8qn7zx2iiqbcdaax335l81a73x9pp8h11yzs2jdmh"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #false))  ;There are none
+    (home-page "https://github.com/gvalkov/optparse-pretty")
+    (synopsis "Compact help formatter for optparse")
+    (description
+     "This module provides two help formatters for optparse.  They provide
+terser and more customizable option formatting in comparison to the default
+help formatter.")
+    (license license:bsd-3)))
+
 (define-public python-orjson
   (package
     (name "python-orjson")