summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:07:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:46 +0200
commita147928371f5619d8f26c42edabbd9398c40275a (patch)
tree89c65f1106ff2ce2ce27d33ab70259472ae1d85f /gnu/packages
parent073bd5b2aa43c74fe7518241736f36824eb07529 (diff)
downloadguix-a147928371f5619d8f26c42edabbd9398c40275a.tar.gz
gnu: Add texlive-timetable.
* gnu/packages/tex.scm (texlive-timetable): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dd6469c0c9..a9892db6ea 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3861,6 +3861,24 @@ languages.")
 dimensional units, usable both with Plain TeX and with LaTeX.")
     (license license:lppl1.3c)))
 
+(define-public texlive-timetable
+  (package
+    (name "texlive-timetable")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "tex/plain/timetable/")
+             (base32
+              "1lnl8gi2rrzcy688qb8b1ff9yivwxdqmbcfx2ph49aymkxfym97b")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/timetable")
+    (synopsis "Generate timetables")
+    (description
+     "This package provides a highly-configurable package, with nice output
+and simple input.  The macros use a radix sort mechanism so that the order of
+input is not critical.")
+    (license license:lppl)))
+
 (define-public texlive-lcdftypetools
   (package
     (name "texlive-lcdftypetools")