summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-14 23:34:16 +0100
committerMarius Bakke <marius@gnu.org>2022-02-15 00:21:15 +0100
commitb5f7140151f5efd2c9ba02f45cdba48ee5206803 (patch)
tree3ce590a7a42fd538d507381e046b39fd2fc6786c /gnu/packages
parentd21a7695e651171fcc500c671d869371ee599eeb (diff)
downloadguix-b5f7140151f5efd2c9ba02f45cdba48ee5206803.tar.gz
gnu: python-warcio: Fix test failure.
* gnu/packages/python-web.scm (python-warcio)[arguments]: Invoke pytest
directly instead of going through setup.py.  Skip three more tests.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8c638ce439..c5b27f5f51 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5254,16 +5254,22 @@ them to a designated prefix.")
            "11afr6zy3r6rda81010iq496dazg4xid0izg3smg6ighpmvsnzf2"))))
       (build-system python-build-system)
       (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'skip-problematic-tests
-             (lambda _
-               ;; These tests fail due to networking requirements.
-               (substitute* "setup.py"
-                 (("pytest.main\\(\\[" all)
-                  (string-append all "'-k', '"
-                                 (string-append "not test_post_chunked and "
-                                                "not test_remote") "'"))))))))
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (replace 'check
+              (lambda* (#:key tests? #:allow-other-keys)
+                (when tests?
+                  (invoke "pytest" "-vv"
+                          ;; These tests fail due to networking requirements.
+                          "-k" (format #f "not ~a"
+                                       (string-join
+                                        '("test_post_chunked"
+                                          "test_remote"
+                                          "test_capture_http_proxy"
+                                          "test_capture_https_proxy"
+                                          "test_capture_https_proxy_same_session")
+                                        " and not ")))))))))
       (native-inputs
        ;; These inputs are required for the test suite.
        (list python-httpbin python-pytest-cov python-requests